THOR Challenge - CVPR 2017 Workshop Forum

Go back to competition Back to thread list Post in this thread

> Environment always get stuck


I've tried to initialize the environment with all the targets one by one. But it always get stuck somewhere before traversing all the targets.

It seems the environment is very unstable. Any idea why?

Posted by: air @ June 30, 2017, 4:50 p.m.

Could you let me know what version of Python, what platform (Linux, OSX) and provide a snippet of the code you are running?

On OSX there is a log file:

on Linux the log file is located at:
~/.config/unity3d/Allen Institute for Artificial Intelligence/RoboSims Platform - FloorPlan18/Player.log

Depending on your platform, could you paste the last 10 or 20 lines from the appropriate log file?

Posted by: AI2_admin @ June 30, 2017, 5:30 p.m.

Could you also find the version of the robosims pip you have installed?

Posted by: AI2_admin @ June 30, 2017, 5:36 p.m.

No, it doesn't pop out any error. The environment just stops at some task (tasks before that work fine), when I run test.
I've updated my robosims to the newest version. It still gets stuck.
I think this environment may not be well for a challenge. Error like this could waste a lot of time and is something we can not control or debug...

Posted by: air @ July 5, 2017, 3 p.m.

I am also facing the same issue

Posted by: a7b23 @ Dec. 21, 2017, 8:19 a.m.
Post in this thread